• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Budgie/Mate/Ubuntu 18.04 -- Z83-II/W/F -- both Audios + WiFi/BT
#1
N Edit --- newest custom .iso's, posted May 27, 2018
------------------------------
Hi all -- below are Download links for my 3rd & final version custom .iso's for our KODLIX brand Z83-II, Z83-W, & Z83-F devices, to enable both HDMI audio and Audio-out/ Headphone Jack. As Hu (forum Admin) already had all hardware working on Ubuntu "Bionic" except HDMI Audio, these .iso's should provide that last bit. These .iso's are based on 18.04 LTS "Release" versions -- I don't believe these are the "best" that could be done for these Z83 devices -- but they are the best I can do, and will be the last versions I post.

These *may* also work on other Z8350 Atom MiniPC boxes -- BeeLink, Bquel, Ace, WinPro, etc -- that use the same or similar main board and hardware
     --- x5 Z8350 Atom cpu
     --- AmPak AP6255 WiFi/BT (Broadcom BCM43455 radio chip)
     --- bytcr-rt5651 Audio for "Built-in" jack

All hardware including both Audio outputs can now be tested from "Live" USB boot, so you can try these out, without harming your device or your current OS installed on your internal eMMC -- boot the USB and check --- if things don't work, don't Install. That simple . . . 
===========================================================================================================

Customizing these .iso's depends on Linuxium & his "isorespin" process and tools -- but I did add in additional edits and scripts to enable our HDMI Audio and bytcr-rt5651 Audio, and make both available to PulseAudio Server

SO BRIEFLY --- The parts of these .iso's that work perfectly (WiFi, UCM files, etc) are to Linuxium's credit
           --- The parts that may show odd glitches (HDMI & Headphone Audio) are due to my edits, & MY fault

NOTE -- for running Ubuntu & variants on Intel Atom devices, most of us would be no where, without Linuxium's work, research, tools, and info --- 
Please do visit his site -- http://www.linuxiumcomau.blogspot.com -- and consider helping to support his work.  There is a Yellow Button on right-hand side of his pages, & I do believe he would appreciate even modest amounts, to help with his Server & ISP costs, etc. 
==========================================================================================================

ALSO -- if you download an .iso here, you are likely not visiting -- http://www.ubuntu.com/download -- and Canonical misses the opportunity to ask for your support. I did contribute for myself when Downloading the 18.04 "flavors" that I customized for our Z83 devices (as I did with Linuxium) -- but I can't possibly cover for everyone. First, how many would that be -- 2, or 200 ?? I have no idea . . . 

So Please Do visit above "Get Ubuntu" site, and consider that $5, $10, or $20 for an entire Operating System is a bargain --- if we want to see better support for our Hardware, and want to free ourselves of the Activation-robbing beast Micro Soft, then we need to help support Canonical & people like Linuxium, that make it possible.

In my opinion, for Open-Source it isn't about how Much any one person contributes to the Developers & organizations, as how Many of us are willing to step up with something. Small amounts add up, if enough of us contribute . . . 
===========================================================================================================
DOWNLOAD links ---

NOTE -- if you have installed one of my earlier versions & have gotten both Audio outputs enabled and working, there is no need to re-install one of these newer .iso's. The edits to PulseAudio files are the same, only the Install & Troubleshoot process has been improved & shortened.

ALSO -- all these .iso's have Grub2 bootloader spun-in & are bootable as-is. Just write the .iso image to a USB stick . . .
I like Etcher ( http://www.etcher.io ) -- it's free, Open-Source, & available for Linux/ Windows/ Mac OS 

Get customized --
Ubuntu-Desktop 18.04 for Z83-II/ W/ F here >>  https://drive.google.com/open?id=1ZZnBok...Ot6OJRVZ8A
md5sum >>>> 930cd1d0b6f6f8658a4b4a6fe8e97644  ./Z83_linuxium-ubuntu-18.04-desktop-amd64.iso

Ubuntu-Budgie 18.04 for Z83-II/ W/ F here >>   https://drive.google.com/open?id=1NOpkZB...0u0JpuqUJf
md5sum >>>> ed5ca60edd5fb8a0364b47dd5be332e9  ./Z83_linuxium-ubuntu-budgie-18.04-desktop-amd64.iso

Ubuntu-Mate 18.04 for Z83-II/ W/ F  here  >>   https://drive.google.com/open?id=11OU78z...2kYqcVyXLk
md5sum >>>>     238c4afab90b88b36b14a5daa1452472  ./Z83_linuxium-ubuntu-mate-18.04-desktop-amd64.iso

============================================================================================================

FEATURES of all .iso's above - -

        1. 4345r6nvram.txt included & renamed to /lib/firmware/brcm/  -- WiFi/BT up & scanning at "Live" boot
        2. UCM Audio files spun in, via proven method -- these will work, at "Live" boot
        3. edits to PulseAudio configs -- a single script "fix_my_headphone.sh" enables Both Audios
        4. all Hardware working (though Audio may have small oddities/ glitches)
============================================================================================================

ISSUES of all .iso's above -- only glitches are related to the attempt at Both Audios . . .

*** VGA-out is Untested -- (my model, Z83-II, doesn't have it) -- but I made no edits to VGA- or Display- related things, so if VGA 
is working in normal *buntu distros, it will work on these 

       1. No auto-switch on Headphone plug/ unplug -- you DO have to manually switch 
           device on "Output" or "Playback" tab of "Sound Settings" panel 

       2. Specific to Ubuntu-Mate -- in FireFox with YouTube playing, Audio changes only
           take effect by pausing Video/Audio first, then select the other Audio in "Sound Settings."
           I did also test VLC Player (included in Mate), and Audio device can be changed 
           during Playback in VLC -- but only via the "Audio" menu of VLC itself, which overrides
           the system "Sound Settings" panel.  There may be other distro-specific oddities
           in these .iso's, with certain Apps -- Be Aware . . .

        3. Cannot seem to set HDMI Audio as "default" output --
            Headphones are usually active at Re-boot or Log-in, and you won't know unless
            you have something plugged in to both -- and Volume levels may not restore as set, 
            coming back at 100% --- for now, just open Volume Control, check & change "Playback" device & 
            Volume level there--  (Could use Help with "default" & "restore,"  if anyone can . . .)

*** (I do now have some additional edits to set HDMI as default Audio -- see Post #2 below, for a couple methods.)

        4. "Speaker" icon in Notification Panel gets out of sync -- it may show wrong
            device as active, or show Muted while sound is actually playing. Just click 
            it and fiddle buttons/ sliders -- it will catch up (could use Help . . .)
 
        5. Very slight "clipping" when switching outputs, sometimes -- and if Audio is from
            a Video source, there's a milli-second stagger in it also

        6. Headphones audio is weak, even at full volume. Might be improved by adjusting levels
            in "alsamixer" -- Google it, maybe with "bytcr-rt5651 alsamixer settings" 
            --or just set some "over-amplify" on Output tab of Volume Control

         7. Various unspecified "Other" -- these are still "Testing-phase" .iso's,
             but all issues relate to Audio, and my edits there -- all else will be fine.

==========================================================================================================

Install Guide ----

*** Important -- we want to test both Audio outputs, so connect your Z83 device to an HDMI TV or Monitor with
working internal speakers, also plug in some Headphones, and leave both connected throughout 

     1. Boot your prepped USB stick from [F7] menu, & at Grub menu select "Try without Installing"
         (top option) only -- do not Install from Grub menu

     1a. Optional -- connect WiFi & check any Hardware you care to. "LiveBoot" session will see our 
           internal eMMC as an "SD Card" which means the external SD Card slot is unavailable "Live" --
           but it will be seen and working, Installed

     1b. Optional -- test Audio.  [CTRL]+[ALT]+[T] to open Terminal, then type & Enter --- 
    
                            fix_my_headphones.sh

          Next open your "Sound" panel of System Settings -- both Audios will be listed now, so launch some Audio
          playback (browser/ YouTube is easiest) and check both (be aware of Mate specific Issue #2 above . . )
-----------------------

     2. If "Live" tests satisfy, Install from Desktop launcher -- first close all other Apps

     ** Optional but Recommended -- before Installing, open File Manager -- in Left sidebar, 
     right-click the "30 GB Volume" (or "60 GB" for 64 GB models) -- if "Unmount" is an option
     on pop-up menu, click it, to Unmount the internal eMMC. If "Mount" is listed, the eMMC is not 
     currently Mounted, so just click out of the pop-up to close. Then close File Manager and launch 
     the Install icon on the Desktop.

     2a. If prompted for "Normal" or "Minimal" Install, you can try either -- I've only tested "Normal"
           but the Minimal *should* include all the PulseAudio components we need for both Audios

           On same panel, you can select "Download Updates" and "3rd  party Software," or not -- either works.

     2b. Only Select "Erase Disk and Install" -- this is only way I've tested. Let the Installer manage
           Partitioning -- it will come back with mmcblk0p1 as "ESP" and mmcblk0p2 as "ext4" -- just "Continue"

     2c. Follow prompts & enter your Info, through to "Restart Now" . . . 
--------------------------

     3. 1st Installed boot -- re-connect WiFi, and when "Software Updater" pops up 
         (if you selected "Updates" at Install), leave it minimized or in background for now.

     3a. Open a Terminal (from Menu or [CTRL]+[ALT]+[T]), and again type and Enter --

                         fix_my_headphones.sh

     ** NOTE -- when we did this "Live" it applied to the "Live" session only -- this time the
     script operates on our Installed system, and it will hold Audio across re-boots -- You will
     not need to run this at every boot.  However, do not delete this script from /usr/local/bin/ --
     if anything -- an App lockup/hang, Power failure, Kernel or PulseAudio Update -- temporarily 
     disrupts our Audio, running this script again *should* bring it back.

     3b. Open System Settings/Sound panel again, launch Browser/ YouTube or some other Audio, and test both outputs
   
     3c. Open "Software Updater" now, and go ahead with installing updates -- then test Audio again

     3d. Re-boot, and test both Audios one more time --- DONE !!

===============================================================================

I do hope some of you will try these .iso's -- and if so, please do post your results/ comments/ etc in this thread -- PJ
  Reply
#2
POST #2 (added May 29, 2018)
 
To set HDMI Audio as default output ----

Setting HDMI Audio is the more difficult option -- it seems the "Built-in Audio" Headphone
jack installs as the "hardware-preferred" default, so in most cases, no action is needed if you
prefer the Headphone/ Audio-out jack as default.

First, some general info (for those that may need it -- experienced users, bear with us . . .)

PulseAudio refers to devices by index-numbers -- for our devices --
HDMI Audio = index 0
Built-in   = index 1

PulseAudio also refers to Audio inputs as "Source" and Audio Outputs as "Sink"

But PulseAudio gets its sound from 'Alsa' and also refers to it --

alsa_output.plughw_0_2   (this is HDMI Audio-- index 0, device 2)
alsa_output.hw_1_0       (this is Headphones -- index 1, device 0)

To work from the Command Line in a Terminal, and avoid any differences in various "Volume Control"
or "Sound Settings" panels of different Ubuntu distros, there are Pulse Audio Commands (pacmd )
as well as PulseAudio Controls (pactl )-- you can see options with 'pacmd --help' or 'pactl --help'

So to check the current default Audio output, in a Terminal enter --

Code:
pacmd list-sinks | grep -i index


Which returns two lines --

        index: 0
        index: 1

One of those lines will have an asterisk (*) to the left, indicating it is default

To change the default Audio output to HDMI (index 0), we can enter --
Code:
pactl set-default-sink 0

Then check by re-running the previous command (use cursor Up-Arrow key to bring
it back from your Commands Cache, then Enter)

So to make HDMI Audio default at every boot, it may work to add the 'pactl set-default-sink 0' to
a start-up file like rc.local -- or you can make a simple bash script, such as ---

    ------------------------   
Code:
#! /bin/bash

#one-liner to set HDMI Audio default
pactl set-default-sink 0
exit 0
   ------------------------

Save that file as something like 'set-HDMI-default.sh'  -- copy or move it somewhere in your
current executable PATH (such as /usr/local/bin/ ) -- don't forget to set 'execute' permission
Code:
sudo chmod +x /usr/local/bin/set-HDMI-default.sh


Then it *should* work to Add that script to "Application Auto-start" of your "Session and Start-up"
through the Desktop GUI (open your Main Menu and begin typing "session" -- something should appear.
Lubuntu .iso does not have a Search Box in its Main Menu, just hunt through folders for that).

When you find & open "Application Auto-start" (or that tab of "Session & Start-up"), click the
"Add" button. On the pop-up, give it a Name (ie, 'set HDMI Audio'), then in the Command box,
give the full path (my example - /usr/local/bin/set-HDMI-default.sh ), or "Browse" to it.
The Comment box can be anything, or leave blank. Finally, click "Add" on this pop-up also.

Add-Auto-Start_ScreenShot         (or see Attached Screenshot at end)
============================================================================================

The other method to set HDMI Audio as default is to edit a couple of PulseAudio start-up files --
/etc/pulse/default.pa and /etc/pulse/system.pa

'Nano' is really the handiest editor, and available on most Ubuntu variants -- but we will need to
copy some text from one file to the other, and I am not sure how to do that with 'nano'.  
I'll write this up with 'gedit' (Ubuntu text editor) and just sub the default Text Editor
of your flavor (mousepad for Xubuntu, leafpad/Lubuntu, pluma/Mate)

Edit default.pa first --       
Code:
sudo gedit /etc/pulse/default.pa


When it opens, arrow down to this block --

      ### Automatically restore the default sink/source when changed by the user
      ### during runtime
      ### NOTE: This should be loaded as early as possible so that subsequent modules
       ### that look up the default sink/source get the right value
      load-module module-default-device-restore

NOTE -- if I understand this, that module over-rides any 'user' attempts to change default-sink,
instead restoring a "system-preferred" or "hardware-preferred" default-device at re-boot/ login.
So we need to #comment with a leading '#' to bypass that load-module --

      #load-module module-default-device-restore

Next arrow down to the end, to this block --

      ### Make some devices default
      #set-default-sink output
      #set-default-source input

Delete the '#" to Un-comment the default-sink line, and edit to match --

      ### Make some devices default
      set-default-sink alsa_output.plughw_0_2
      #set-default-source input

Next, 'Save' the file, but do not 'Close' it yet -- Highlight those last 3 Lines (as above) & press
[CTRL]+[C] to Copy. With that on the clipboard, now 'Close' the /etc/pulse/default.pa file

-------------------------
(NOTE -- I am not certain it's necessary to edit system.pa -- but it also won't hurt anything.
To minimize possibility of conflicts, I tend to enter same edits to both default.pa & system.pa,
and keep them broadly in agreement.  -- PJ)
-------------------------

Back in Terminal, now open system.pa to edit --
  
Code:
sudo gedit /etc/pulse/system.pa


Move your Cursor to the END of the last line in this file, then press [ENTER] once for a blank
line, then once more for a new line to Paste to.  Now press [CTRL]+[V] to Paste our "defaults"
block. The last two blocks should now look like this - - -

      ### Enable positioned event sounds
      load-module module-position-event-sounds

      ### Make some devices default
      set-default-sink alsa_output.plughw_0_2
      #set-default-source input

Now arrow back up this file, and find the same "module-default-device-restore" line here in
system.pa also. Again, #comment this line, as below --

      #load-module module-default-device-restore

Now 'Save' and 'Close' this file, /etc/pulse/system.pa
-----------------------------------------------

With editing done, we need to re-start PulseAudio, to load these changes -- it should be set to
"auto-spawn" so just --kill should also re-start PulseAudio --
  
Code:
pulseaudio -k

Now we can again 'grep' for just those lines that include (-i) 'index' of our PulseAudio sinks

Code:
pacmd list-sinks | grep -i index

This time the '*' asterisk should be beside 'index: 0' -- showing we have successfully set HDMI Audio
output as the default, and our other edits should make that durable across re-boots/ power cycles.

--------------------------------------------------

One last thing to check -- PulseAudio also creates some settings in a 'pulse' folder within the
hidden '.config' folder in userspace -- your "Home" folder. The full path is --

        /home/{YOUR_USERNAME}/.config/pulse/

So open your 'Home' folder in File Manager, and look for 'Show Hidden' toggle (it's on 'View' menu
of those distros that have a Menu Bar, or on the 3-bars Menu at upper-right for Ubuntu & Budgie) --
When you find it, click to checkmark 'Show Hidden'

Next open the '.config' folder that appears, and within it, the 'pulse' folder -- there should be
five files, plus a 'cookie.' We only need to check one file ---

        {long-string-of-characters}-default-sink

Double-click it, it will open in your default text editor. This should be a single line of text --

        alsa_output.plughw_0_2

If it says anything else, edit to match the line above -- then 'Save' and 'Close'

---------------------------------------------------

That's it --- this will reliably and durably set HDMI Audio as 'default' output
(tho Headphones are still available to switch to, in Sound settings or Volume Control, etc.)


Attached Files Thumbnail(s)
   
  Reply
#3
I downloaded Z83_linuxium-ubuntu-mate-18.04-desktop-amd64.iso referred to in the first post, and just installed on a new Z83-W (2/32).

It doesn't work. It installs fine, but neither the wifi nor audio work. Not worried about wifi, I can fix that, but was hoping to find a working built-in (not HDMI) audio.

When I go to sounds it won't allow me to select the built in and make it stick (it selects, it just isn't selected when I come back). Top right speaker icon is grey and muted. Under Sound there is no test for the speakers. I tried both firefox (youtube) and rhythmbox and could not get sound. The sound hardware works, I installed W10pro and tested it.

I separately tried to make it work myself from various instructions without success (though I could get it to show up). See http://www.minisforum.com/showthread.php?tid=405

SHould the mate version above work? Could there have been board changes over the last 5 months or so since your posting?

aplay -l shows card 1 as a bytcrrt5651, with a device 0 as audio and device 1 as Deep-buffer audio.
  Reply
#4
(10-12-2018, 08:57 PM)Linwood Wrote: I downloaded Z83_linuxium-ubuntu-mate-18.04-desktop-amd64.iso referred to in the first post, and just installed on a new Z83-W (2/32).

It doesn't work.  It installs fine, but neither the wifi nor audio work.  Not worried about wifi, I can fix that, but was hoping to find a working built-in (not HDMI) audio.

When I go to sounds it won't allow me to select the built in and make it stick (it selects, it just isn't selected when I come back).  Top right speaker icon is grey and muted.  Under Sound there is no test for the speakers.  I tried both firefox (youtube) and rhythmbox and could not get sound.  The sound hardware works, I installed W10pro and tested it.

I separately tried to make it work myself from various instructions without success (though I could get it to show up).   See http://www.minisforum.com/showthread.php?tid=405

SHould the mate version above work?   Could there have been board changes over the last 5 months or so since your posting?

aplay -l shows card 1 as a bytcrrt5651, with a device 0 as audio and device 1 as Deep-buffer audio.
Did you run the bash script after Install ?? 
If not, open a terminal & enter --

     fix_my_headphones.sh

That *should* run an ALSA enabling command to activate your Audio.
Second post above has detailed instructions to set either HDMI or Headphone/Audio jack as durable default -- PJ
  Reply
#5
(10-14-2018, 01:37 PM)PrairieJohn Wrote:
(10-12-2018, 08:57 PM)Linwood Wrote: I downloaded Z83_linuxium-ubuntu-mate-18.04-desktop-amd64.iso referred to in the first post, and just installed on a new Z83-W (2/32).

It doesn't work.  It installs fine, but neither the wifi nor audio work.  Not worried about wifi, I can fix that, but was hoping to find a working built-in (not HDMI) audio.

When I go to sounds it won't allow me to select the built in and make it stick (it selects, it just isn't selected when I come back).  Top right speaker icon is grey and muted.  Under Sound there is no test for the speakers.  I tried both firefox (youtube) and rhythmbox and could not get sound.  The sound hardware works, I installed W10pro and tested it.

I separately tried to make it work myself from various instructions without success (though I could get it to show up).   See http://www.minisforum.com/showthread.php?tid=405

SHould the mate version above work?   Could there have been board changes over the last 5 months or so since your posting?

aplay -l shows card 1 as a bytcrrt5651, with a device 0 as audio and device 1 as Deep-buffer audio.
Did you run the bash script after Install ?? 
If not, open a terminal & enter --

     fix_my_headphones.sh

That *should* run an ALSA enabling command to activate your Audio.
Second post above has detailed instructions to set either HDMI or Headphone/Audio jack as durable default -- PJ

No.  I'll redo the test tomorrow and see what I can get.   I thought that was just to get it to switch between speakers and headphones, maybe I misunderstood.  Will try again.  I actually made some progress (on 18.10 dailies though not sure if significant) by NOT using the linked text files, just blacklisting the hdmi seems to work. Using the referenced text files causes the output to be mono, weirdly enough.
  Reply
#6
@PrairieJohn, I tested it again. I copied the Mate variant to USB, and booted as Live, then ran the fix_my_headphones.sh script.

The results were confusing.

Under Sound, Hardware, nothing is shown.

However, it's shown under output, and it does output.

I did a "speakertest -t wav -c 2" and as I did with the manual fixes elsewhere, I got mono output, meaning both front-left and front-right played through both ears at the same volume.

So fundamentally - no, it does not work for me. Did you ever test that you really got stereo, or just that you got audio?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)